You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by DKW (Jun 3rd 2016, 10:11am)

3 78

by mrfixit

(Jun 6th 2016, 2:22pm)

by BostonStrong (Apr 26th 2016, 5:45pm)

3 135

by BostonStrong

(Apr 27th 2016, 8:33pm)

by cmoore (Mar 27th 2016, 6:32am)

3 282

by Wet_Boots

(Apr 2nd 2016, 10:52am)

by kp007 (Mar 22nd 2016, 10:42am)

3 102

by Wet_Boots

(Mar 22nd 2016, 12:35pm)

by dsmayse (Oct 24th 2015, 10:43am)

3 839

by Wet_Boots

(Oct 25th 2015, 5:55pm)

by Dagobah (Sep 3rd 2015, 3:46pm)

3 791

by Evergreen Sprinkler

(Sep 11th 2015, 9:41am)

by denver9 (Aug 10th 2015, 10:47pm)

3 424

by Wet_Boots

(Aug 12th 2015, 3:44am)

by sijaz (Aug 11th 2015, 12:25am)

3 435

by mrfixit

(Aug 11th 2015, 2:35pm)

by CRASH (Aug 6th 2015, 6:02pm)

3 212

by Wet boots

(Aug 7th 2015, 3:30pm)

by Reg1987 (Jul 12th 2015, 7:43pm)

3 158

by Wet_Boots

(Jul 14th 2015, 6:12pm)

Show

Statistics:

517 Threads - 1,975 Posts (average 0.37 Posts per Day)