You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by tbatrof (Sep 10th 2011, 7:00pm)

2 290

by mrfixit

(Sep 10th 2011, 10:07pm)

by maddog (Sep 8th 2011, 5:48pm)

1 224

by grey

(Sep 9th 2011, 11:40am)

by Jimy (Aug 30th 2011, 11:45am)

4 605

by chrisrlewis78

(Sep 4th 2011, 2:52pm)

by evergreenz (Sep 3rd 2011, 2:33am)

2 204

by evergreenz

(Sep 3rd 2011, 12:08pm)

by chrisrlewis78 (Aug 4th 2011, 6:51pm)

18 2,255

by chrisrlewis78

(Aug 31st 2011, 4:50pm)

by lbfalgi (Aug 30th 2011, 6:15pm)

1 989

by Central Irrigation

(Aug 30th 2011, 8:38pm)

by Mindy (Aug 23rd 2011, 12:33pm)

1 181

by Wet_Boots

(Aug 23rd 2011, 2:30pm)

by horse_98 (Aug 22nd 2011, 4:03pm)

2 185

by Wet_Boots

(Aug 23rd 2011, 11:43am)

by John199 (Aug 14th 2011, 3:57pm)

4 747

by hi.todd

(Aug 15th 2011, 7:29pm)

by clm716 (Aug 7th 2011, 9:58am)

1 219

by Central Irrigation

(Aug 7th 2011, 10:49am)

Show

Statistics:

464 Threads - 1,709 Posts (average 0.37 Posts per Day)