You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by tbtech24 (Jun 9th 2011, 9:24am)

3 887

by Wet_Boots

(Jun 9th 2011, 10:09am)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 885

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by ianmac (Apr 25th 2011, 10:45pm)

1 883

by Wet_Boots

(Apr 26th 2011, 9:20am)

by garen (Aug 8th 2012, 10:41pm)

7 882

by Wet_Boots

(Aug 24th 2012, 8:00am)

by rspfau (Jun 9th 2011, 6:12pm)

4 877

by Mitchgo

(Jun 9th 2011, 10:08pm)

by Texas Guy (May 23rd 2006, 5:48pm)

0 876

No reply

by nrwe (Jul 19th 2012, 1:57pm)

4 873

by mrfixit

(Jul 20th 2012, 3:06pm)

by xfevv (Oct 16th 2007, 4:52am)

4 873

by Cricketkiller

(Jun 7th 2008, 3:53pm)

by HHicks (Jul 22nd 2011, 4:57pm)

1 869

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

by Drski (Jul 29th 2011, 11:50am)

5 868

by Drski

(Aug 9th 2011, 11:04am)

Show

Statistics:

497 Threads - 1,879 Posts (average 0.36 Posts per Day)