You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ianmac (Apr 25th 2011, 10:45pm)

1 849

by Wet_Boots

(Apr 26th 2011, 9:20am)

by Drski (Jul 29th 2011, 11:50am)

5 847

by Drski

(Aug 9th 2011, 11:04am)

by nrwe (Jul 19th 2012, 1:57pm)

4 845

by mrfixit

(Jul 20th 2012, 3:06pm)

by HHicks (Jul 22nd 2011, 4:57pm)

1 845

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

by lou40 (Nov 9th 2011, 4:15pm)

3 838

by Wet_Boots

(Nov 13th 2011, 8:15am)

by fireman (Sep 15th 2006, 3:14pm)

8 838

by mrfixit

(Sep 19th 2006, 9:59am)

by kenken55 (Aug 5th 2010, 10:55am)

2 836

by kenken1955

(Aug 28th 2010, 5:32am)

by Dennis (Oct 15th 2007, 7:30am)

1 823

by edwildesr

(Nov 5th 2007, 7:53am)

by BenC (Apr 10th 2007, 6:32pm)

7 808

by BenC

(Apr 17th 2007, 5:38pm)

by rsteffan (Aug 1st 2012, 6:14pm)

6 793

by Wet_Boots

(Aug 22nd 2012, 10:52am)

Show

Statistics:

485 Threads - 1,829 Posts (average 0.36 Posts per Day)