You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by GraemeDunkley (May 4th 2013, 10:50pm)

5 903

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by ianmac (Apr 25th 2011, 10:45pm)

1 902

by Wet_Boots

(Apr 26th 2011, 9:20am)

by tbtech24 (Jun 9th 2011, 9:24am)

3 899

by Wet_Boots

(Jun 9th 2011, 10:09am)

by garen (Aug 8th 2012, 10:41pm)

7 892

by Wet_Boots

(Aug 24th 2012, 8:00am)

by nrwe (Jul 19th 2012, 1:57pm)

4 887

by mrfixit

(Jul 20th 2012, 3:06pm)

by Texas Guy (May 23rd 2006, 5:48pm)

0 887

No reply

by rspfau (Jun 9th 2011, 6:12pm)

4 886

by Mitchgo

(Jun 9th 2011, 10:08pm)

by Drski (Jul 29th 2011, 11:50am)

5 880

by Drski

(Aug 9th 2011, 11:04am)

by HHicks (Jul 22nd 2011, 4:57pm)

1 878

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

by xfevv (Oct 16th 2007, 4:52am)

4 878

by Cricketkiller

(Jun 7th 2008, 3:53pm)

Show

Statistics:

500 Threads - 1,903 Posts (average 0.37 Posts per Day)