You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by mikesegall@aol.com (Dec 25th 2012, 6:20pm)

1 398

by Wet_Boots

(Dec 26th 2012, 8:32am)

by garen (Aug 8th 2012, 10:41pm)

7 551

by Wet_Boots

(Aug 24th 2012, 8:00am)

by perplexed (Sep 8th 2007, 3:35am)

4 510

by perplexed

(Sep 9th 2007, 5:20am)

by stephen (May 2nd 2010, 12:11pm)

0 120

No reply

by Smithwilde (Aug 1st 2011, 1:23pm)

5 231

by Smithwilde

(Aug 1st 2011, 8:37pm)

by mulletmac (Sep 30th 2011, 7:29am)

2 386

by mulletmac

(Oct 1st 2011, 11:26am)

by jcmckinney1 (Oct 6th 2011, 10:38am)

1 161

by Wet_Boots

(Oct 6th 2011, 6:55pm)

by mahplane (Apr 26th 2010, 5:49pm)

0 274

No reply

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 257

by mrfixit

(Apr 17th 2013, 5:56pm)

by tico (Jun 15th 2013, 8:58pm)

0 355

No reply

Show

Statistics:

436 Threads - 1,648 Posts (average 0.36 Posts per Day)