You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by CRASH (Aug 6th 2015, 6:02pm)

3 134

by Wet boots

(Aug 7th 2015, 3:30pm)

by Reg1987 (Jul 12th 2015, 7:43pm)

3 85

by Wet_Boots

(Jul 14th 2015, 6:12pm)

by MAG128 (Jun 24th 2015, 5:32pm)

3 200

by Wet_Boots

(Jun 26th 2015, 6:20am)

by Roco8823 (Jun 22nd 2015, 11:43pm)

3 77

by mrfixit

(Jun 23rd 2015, 11:44am)

by rchead755 (Aug 23rd 2014, 11:36am)

3 269

by mirassou

(May 27th 2015, 5:26pm)

by hlsrtony (May 26th 2015, 2:28pm)

3 168

by mrfixit

(May 27th 2015, 3:10pm)

by PabloCruise (May 3rd 2015, 4:28pm)

3 73

by Wet_Boots

(May 4th 2015, 11:53am)

by LT87 (May 21st 2014, 11:33am)

3 207

by hi.todd

(May 27th 2014, 1:03pm)

by andyl (Apr 21st 2014, 8:32pm)

3 300

by Wet_Boots

(Apr 27th 2014, 9:26am)

by nightshark (Sep 9th 2013, 3:11pm)

3 690

by mrfixit

(Sep 9th 2013, 6:05pm)

Show

Statistics:

477 Threads - 1,795 Posts (average 0.36 Posts per Day)