You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by dunn (Jun 29th 2005, 3:35am)

4 772

by Wet_Boots

(Jul 4th 2005, 6:22am)

by dsmayse (Oct 24th 2015, 10:43am)

3 679

by Wet_Boots

(Oct 25th 2015, 5:55pm)

by Dagobah (Sep 3rd 2015, 3:46pm)

3 592

by Evergreen Sprinkler

(Sep 11th 2015, 9:41am)

by denver9 (Aug 10th 2015, 10:47pm)

3 378

by Wet_Boots

(Aug 12th 2015, 3:44am)

by sijaz (Aug 11th 2015, 12:25am)

3 350

by mrfixit

(Aug 11th 2015, 2:35pm)

by CRASH (Aug 6th 2015, 6:02pm)

3 192

by Wet boots

(Aug 7th 2015, 3:30pm)

by Reg1987 (Jul 12th 2015, 7:43pm)

3 135

by Wet_Boots

(Jul 14th 2015, 6:12pm)

by MAG128 (Jun 24th 2015, 5:32pm)

3 263

by Wet_Boots

(Jun 26th 2015, 6:20am)

by Roco8823 (Jun 22nd 2015, 11:43pm)

3 138

by mrfixit

(Jun 23rd 2015, 11:44am)

by rchead755 (Aug 23rd 2014, 11:36am)

3 361

by mirassou

(May 27th 2015, 5:26pm)

Show

Statistics:

486 Threads - 1,840 Posts (average 0.36 Posts per Day)