You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by JAshburn (Apr 23rd 2014, 10:04pm)

3 115

by Wet_Boots

(Apr 24th 2014, 4:22pm)

by Oscar S. Ramirez (Mar 21st 2014, 5:28pm)

1 187

by mrfixit

(Mar 22nd 2014, 1:58am)

by PerryNZ (Mar 12th 2014, 10:57pm)

5 192

by PerryNZ

(Mar 14th 2014, 12:16am)

by beachdoc (May 19th 2012, 1:37pm)

5 986

by pavelow

(Oct 30th 2013, 9:51pm)

by betsycam (Oct 13th 2013, 4:26pm)

1 444

by Wet_Boots

(Oct 14th 2013, 10:18am)

by birdwatcher (Sep 30th 2013, 1:59pm)

1 240

by mrfixit

(Sep 30th 2013, 5:32pm)

by nightshark (Sep 9th 2013, 3:11pm)

3 466

by mrfixit

(Sep 9th 2013, 6:05pm)

by Gansmanms (Nov 7th 2012, 9:10pm)

7 1,333

by marian

(Sep 2nd 2013, 5:37pm)

by mydogcleo (Aug 28th 2013, 10:11am)

1 257

by Wet_Boots

(Aug 28th 2013, 1:36pm)

by Bwilson2 (Aug 13th 2013, 10:12pm)

2 309

by mrfixit

(Aug 14th 2013, 12:28pm)

Show

Statistics:

436 Threads - 1,648 Posts (average 0.36 Posts per Day)