You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Freddyfrom fl (Aug 6th 2013, 6:49pm)

1 379

by Wet_Boots

(Aug 6th 2013, 9:29pm)

by sdguy (Mar 10th 2013, 3:15pm)

3 785

by Wet_Boots

(Jul 31st 2013, 10:41am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 1,196

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by Pippilo (Jul 1st 2013, 9:15pm)

3 663

by mrfixit

(Jul 2nd 2013, 3:07am)

by 7907 (May 3rd 2013, 12:55am)

2 494

by PennyInHeels

(Jun 25th 2013, 9:49am)

by Rmiclette (May 5th 2013, 6:49am)

2 548

by Scott76

(May 5th 2013, 11:41am)

by Caltino (Apr 12th 2013, 7:18pm)

12 1,845

by Wet_Boots

(Apr 27th 2013, 7:42am)

by Marvel (Jan 19th 2013, 6:54am)

7 1,671

by Marvel

(Jan 22nd 2013, 7:49pm)

by dgaines (Nov 5th 2012, 5:27pm)

3 1,152

by dgaines

(Nov 10th 2012, 4:15pm)

by njchoochoo1 (Oct 16th 2012, 8:13pm)

3 1,989

by Wet_Boots

(Oct 18th 2012, 9:14am)

Show

Statistics:

505 Threads - 1,935 Posts (average 0.37 Posts per Day)