You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by clm716 (Aug 7th 2011, 9:58am)

1 380

by Central Irrigation

(Aug 7th 2011, 10:49am)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 382

by jmduke7

(Aug 16th 2006, 6:36pm)

by 0303maz (Jun 12th 2012, 9:20am)

1 385

by mrfixit

(Jun 12th 2012, 9:45am)

by wetyet (Apr 6th 2006, 4:16pm)

2 386

by wetyet

(Apr 7th 2006, 4:01pm)

by SteveM099 (Jun 19th 2006, 1:50am)

1 387

by Wet_Boots

(Jun 19th 2006, 6:17am)

by MEL88 (Jul 19th 2012, 12:20pm)

1 390

by GatorGuy

(Jul 19th 2012, 2:14pm)

by lkc91311 (Jun 26th 2011, 11:25pm)

0 390

No reply

by joe decoste (Mar 19th 2011, 11:56am)

1 390

by Wet_Boots

(Mar 20th 2011, 7:29am)

by SpritzCan (Apr 21st 2012, 8:33pm)

2 391

by GatorGuy

(Apr 23rd 2012, 8:47am)

by horse_98 (Aug 22nd 2011, 4:03pm)

2 392

by Wet_Boots

(Aug 23rd 2011, 11:43am)

Show

Statistics:

513 Threads - 1,964 Posts (average 0.37 Posts per Day)