You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by joe decoste (Mar 19th 2011, 11:56am)

1 363

by Wet_Boots

(Mar 20th 2011, 7:29am)

by SteveM099 (Jun 19th 2006, 1:50am)

1 363

by Wet_Boots

(Jun 19th 2006, 6:17am)

by Towelie427 (Sep 1st 2014, 7:10pm)

4 366

by Wet_Boots

(Oct 5th 2014, 2:45pm)

by billt (Aug 28th 2010, 10:20am)

1 366

by Wet_Boots

(Aug 28th 2010, 11:21am)

by bron7fan@cox.net (Oct 15th 2011, 5:15pm)

2 369

by mrfixit

(Oct 16th 2011, 2:26am)

by maddog (Sep 8th 2011, 5:48pm)

1 369

by grey

(Sep 9th 2011, 11:40am)

by keitht (Apr 11th 2006, 3:53pm)

1 372

by BSME

(Apr 12th 2006, 5:45am)

by runningfreak (May 25th 2011, 7:32pm)

1 374

by Wet_Boots

(May 25th 2011, 8:29pm)

by Kim (Jun 19th 2010, 6:45am)

1 375

by mrfixit

(Jun 19th 2010, 12:11pm)

by Hammy69 (Jun 16th 2009, 9:46am)

1 375

by hi.todd

(Jun 19th 2009, 10:29pm)

Show

Statistics:

506 Threads - 1,938 Posts (average 0.37 Posts per Day)