You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Moggie (Jun 4th 2011, 10:48am)

1 277

by Mitchgo

(Jun 5th 2011, 1:28pm)

by melprint (Jul 11th 2009, 9:06am)

1 280

by mrfixit

(Jul 11th 2009, 11:59am)

by Rendaug (Jan 18th 2004, 12:31pm)

3 281

by Rendaug

(Feb 8th 2004, 10:37am)

by pjmckellar (Jul 27th 2013, 8:25am)

1 284

by Central Irrigation

(Jul 27th 2013, 9:42am)

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 284

by HooKooDooKu

(Jun 9th 2010, 11:12am)

by julieblades (Jan 7th 2006, 6:27am)

6 287

by Mudpuppy

(Oct 12th 2006, 6:03pm)

by chpsk8 (Mar 17th 2002, 5:25am)

1 287

by RVLI

(Mar 20th 2002, 12:31pm)

by The Professor (May 26th 2005, 9:47pm)

2 288

by Jazzer K

(Sep 2nd 2005, 6:19pm)

by birdwatcher (Sep 30th 2013, 1:59pm)

1 290

by mrfixit

(Sep 30th 2013, 5:32pm)

by Wet_Boots (May 8th 2011, 7:43am)

0 290

No reply

Show

Statistics:

436 Threads - 1,669 Posts (average 0.35 Posts per Day)