You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Kpierce (Apr 12th 2013, 10:36pm)

1 285

by Wet_Boots

(Apr 13th 2013, 10:46am)

by melprint (Jul 11th 2009, 9:06am)

1 287

by mrfixit

(Jul 11th 2009, 11:59am)

by Sandart (May 25th 2006, 3:16pm)

2 291

by jlease

(May 28th 2006, 10:06am)

by Rendaug (Jan 18th 2004, 12:31pm)

3 292

by Rendaug

(Feb 8th 2004, 10:37am)

by The Professor (May 26th 2005, 9:47pm)

2 293

by Jazzer K

(Sep 2nd 2005, 6:19pm)

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 294

by HooKooDooKu

(Jun 9th 2010, 11:12am)

by pjmckellar (Jul 27th 2013, 8:25am)

1 295

by Central Irrigation

(Jul 27th 2013, 9:42am)

by mosida (Sep 29th 2004, 9:16am)

3 296

by nestors

(Oct 31st 2004, 1:27pm)

by chpsk8 (Mar 17th 2002, 5:25am)

1 296

by RVLI

(Mar 20th 2002, 12:31pm)

by Wet_Boots (May 8th 2011, 7:43am)

0 298

No reply

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)