You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Jimy (Aug 30th 2011, 11:45am)

4 880

by chrisrlewis78

(Sep 4th 2011, 2:52pm)

by slemani62 (Jul 29th 2010, 2:56pm)

1 879

by mrfixit

(Jul 29th 2010, 6:35pm)

by RT (Oct 12th 2011, 8:10pm)

1 878

by mrfixit

(Oct 12th 2011, 11:29pm)

by tbtech24 (Jun 9th 2011, 9:24am)

3 873

by Wet_Boots

(Jun 9th 2011, 10:09am)

by lonnieclar (Jul 22nd 2008, 7:06pm)

1 873

by mrfixit

(Jul 22nd 2008, 9:30pm)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 870

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by garen (Aug 8th 2012, 10:41pm)

7 863

by Wet_Boots

(Aug 24th 2012, 8:00am)

by rspfau (Jun 9th 2011, 6:12pm)

4 860

by Mitchgo

(Jun 9th 2011, 10:08pm)

by Texas Guy (May 23rd 2006, 5:48pm)

0 855

No reply

by xfevv (Oct 16th 2007, 4:52am)

4 853

by Cricketkiller

(Jun 7th 2008, 3:53pm)

Show

Statistics:

485 Threads - 1,832 Posts (average 0.36 Posts per Day)