You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by dunn (Jun 29th 2005, 3:35am)

4 383

by Wet_Boots

(Jul 4th 2005, 6:22am)

by lbfalgi (Aug 30th 2011, 6:15pm)

1 919

by Central Irrigation

(Aug 30th 2011, 8:38pm)

by Garden Guy (May 7th 2007, 9:22am)

10 803

by lush96

(May 14th 2007, 8:22pm)

by rsteffan (Aug 1st 2012, 6:14pm)

6 489

by Wet_Boots

(Aug 22nd 2012, 10:52am)

by tkbryant (Dec 26th 2005, 12:59pm)

4 1,797

by lush96

(Mar 19th 2006, 7:49pm)

by Cherrybark (May 20th 2012, 6:22pm)

2 316

by GatorGuy

(May 21st 2012, 9:04am)

by jzb18134 (Sep 7th 2011, 3:55pm)

6 385

by CRI IRR

(Sep 13th 2011, 6:34am)

by jkd1976@yahoo.com (Mar 15th 2007, 4:11pm)

7 767

by SprinklerGuy

(Mar 17th 2007, 2:22am)

by kannan (May 18th 2011, 5:07pm)

4 1,253

by Wet_Boots

(May 27th 2012, 10:31am)

by TxDoc (Aug 30th 2014, 7:27pm)

1 22

by Wet_Boots

(Aug 31st 2014, 8:54am)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)