You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by jcmckinney1 (Oct 6th 2011, 10:38am)

1 275

by Wet_Boots

(Oct 6th 2011, 6:55pm)

by danny1949 (Sep 22nd 2011, 12:04pm)

1 325

by Wet_Boots

(Sep 22nd 2011, 5:05pm)

by maddog (Sep 8th 2011, 5:48pm)

1 298

by grey

(Sep 9th 2011, 11:40am)

by lbfalgi (Aug 30th 2011, 6:15pm)

1 1,467

by Central Irrigation

(Aug 30th 2011, 8:38pm)

by Mindy (Aug 23rd 2011, 12:33pm)

1 258

by Wet_Boots

(Aug 23rd 2011, 2:30pm)

by bluetractormanc (Aug 9th 2011, 10:59pm)

1 891

by Wet_Boots

(Aug 10th 2011, 7:51am)

by clm716 (Aug 7th 2011, 9:58am)

1 303

by Central Irrigation

(Aug 7th 2011, 10:49am)

by BirdieBob (Aug 4th 2011, 7:01pm)

1 265

by Wet_Boots

(Aug 4th 2011, 9:27pm)

by JohnEmery (Jul 31st 2011, 3:48pm)

1 559

by Wet_Boots

(Jul 31st 2011, 4:16pm)

by JimB (Jul 30th 2011, 3:59pm)

1 259

by Wet_Boots

(Jul 30th 2011, 4:53pm)



479 Threads - 1,805 Posts (average 0.36 Posts per Day)