You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by avu3 (Jul 3rd 2005, 2:36pm)

4 256

by avu3

(Jul 4th 2005, 7:20pm)

by dunn (Jun 29th 2005, 3:35am)

4 358

by Wet_Boots

(Jul 4th 2005, 6:22am)

by LT87 (May 21st 2014, 11:33am)

3 87

by hi.todd

(May 27th 2014, 1:03pm)

by andyl (Apr 21st 2014, 8:32pm)

3 100

by Wet_Boots

(Apr 27th 2014, 9:26am)

by JAshburn (Apr 23rd 2014, 10:04pm)

3 80

by Wet_Boots

(Apr 24th 2014, 4:22pm)

by nightshark (Sep 9th 2013, 3:11pm)

3 404

by mrfixit

(Sep 9th 2013, 6:05pm)

by sdguy (Mar 10th 2013, 3:15pm)

3 363

by Wet_Boots

(Jul 31st 2013, 10:41am)

by Pippilo (Jul 1st 2013, 9:15pm)

3 273

by mrfixit

(Jul 2nd 2013, 3:07am)

by BessMan94 (Jun 24th 2013, 8:45pm)

3 256

by mrfixit

(Jun 25th 2013, 8:32pm)

by gobris (May 14th 2013, 9:45am)

3 347

by Wet_Boots

(May 16th 2013, 8:30am)

Show

Statistics:

430 Threads - 1,626 Posts (average 0.36 Posts per Day)