You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by LawnJockey (Oct 29th 2011, 10:39am)

1 632

by mrfixit

(Oct 29th 2011, 1:33pm)

by Neil7 (Oct 24th 2011, 5:19pm)

5 259

by Neil7

(Oct 25th 2011, 8:44pm)

by hudr0004 (Sep 12th 2011, 10:16am)

4 389

by hudr0004

(Oct 24th 2011, 8:38am)

by jeffg (Oct 22nd 2011, 6:06pm)

1 337

by Wet_Boots

(Oct 23rd 2011, 11:52am)

by brknpcs1 (Sep 7th 2011, 10:36pm)

4 215

by Wet_Boots

(Oct 22nd 2011, 1:34pm)

by bdt (Oct 17th 2011, 9:50am)

2 299

by Mitchgo

(Oct 17th 2011, 12:59pm)

by bron7fan@cox.net (Oct 15th 2011, 5:15pm)

2 118

by mrfixit

(Oct 16th 2011, 2:26am)

by pphilt (Oct 9th 2011, 9:55pm)

5 211

by JimmyTheGlove

(Oct 13th 2011, 3:24pm)

by RT (Oct 12th 2011, 8:10pm)

1 440

by mrfixit

(Oct 12th 2011, 11:29pm)

by jcmckinney1 (Oct 6th 2011, 10:38am)

1 122

by Wet_Boots

(Oct 6th 2011, 6:55pm)

Show

Statistics:

420 Threads - 1,567 Posts (average 0.35 Posts per Day)