You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by whitty (Apr 20th 2012, 8:09am)

10 529

by GatorGuy

(Apr 23rd 2012, 8:45am)

by mack (Apr 18th 2012, 8:30pm)

2 456

by mack

(Apr 19th 2012, 12:54pm)

by jack z (Apr 8th 2012, 10:35am)

1 406

by mrfixit

(Apr 8th 2012, 2:37pm)

by opsec (Apr 1st 2012, 7:44pm)

2 438

by Wet_Boots

(Apr 2nd 2012, 9:08am)

by brobinson (Jun 12th 2010, 7:44am)

8 1,976

by Wet_Boots

(Mar 31st 2012, 4:43pm)

by SVKTVKVVK (Mar 22nd 2012, 10:53am)

3 1,620

by mrfixit

(Mar 22nd 2012, 12:43pm)

by ros (Mar 15th 2012, 7:40pm)

1 399

by hi.todd

(Mar 20th 2012, 9:07pm)

by aa1872 (Mar 17th 2012, 8:22am)

3 230

by GatorGuy

(Mar 19th 2012, 8:41am)

by Jonas_ (Mar 13th 2012, 9:40am)

10 1,793

by Wet_Boots

(Mar 16th 2012, 8:14am)

by Jonas_ (Mar 14th 2012, 6:16am)

1 361

by GatorGuy

(Mar 14th 2012, 7:35am)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)