You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Don_Mousseau (May 15th 2010, 8:44am)

1 567

by mrfixit

(May 15th 2010, 1:03pm)

by Brie (Feb 24th 2009, 11:42am)

2 564

by sanzen96

(Mar 21st 2009, 3:55pm)

by zenavttmn (Apr 22nd 2006, 9:25am)

5 564

by zenavttmn

(Apr 24th 2006, 1:21pm)

by Dennis (Oct 15th 2007, 7:30am)

1 558

by edwildesr

(Nov 5th 2007, 7:53am)

by ianmac (Apr 25th 2011, 10:45pm)

1 556

by Wet_Boots

(Apr 26th 2011, 9:20am)

by RT (Oct 12th 2011, 8:10pm)

1 554

by mrfixit

(Oct 12th 2011, 11:29pm)

by orgits (Apr 9th 2011, 5:10pm)

2 552

by Mitchgo

(Apr 10th 2011, 2:29am)

by lou40 (Nov 9th 2011, 4:15pm)

3 548

by Wet_Boots

(Nov 13th 2011, 8:15am)

by Michael (May 1st 2006, 3:41pm)

4 537

by Michael

(May 2nd 2006, 3:25am)

by Fapp (Feb 21st 2005, 10:11am)

3 534

by nestors

(Apr 7th 2005, 8:51am)

Show

Statistics:

431 Threads - 1,630 Posts (average 0.36 Posts per Day)