You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by Gilgaretch (Jun 23rd 2015, 8:23pm)

0 107

No reply

by rchead755 (Aug 23rd 2014, 11:36am)

3 321

by mirassou

(May 27th 2015, 5:26pm)

by buhbuhh (May 19th 2015, 6:00pm)

10 258

by mrfixit

(May 22nd 2015, 10:58pm)

by ASV (May 11th 2015, 6:30am)

1 196

by Wet_Boots

(May 11th 2015, 8:09am)

by PabloCruise (May 3rd 2015, 4:28pm)

3 110

by Wet_Boots

(May 4th 2015, 11:53am)

by DJM8507 (Apr 28th 2015, 12:21pm)

0 133

No reply

by Towelie427 (Sep 1st 2014, 7:10pm)

4 310

by Wet_Boots

(Oct 5th 2014, 2:45pm)

by 95mmrenegade (Jul 20th 2014, 10:30am)

4 209

by Central Irrigation

(Jul 20th 2014, 2:43pm)

by LT87 (May 21st 2014, 11:33am)

3 239

by hi.todd

(May 27th 2014, 1:03pm)

by andyl (Apr 21st 2014, 8:32pm)

3 349

by Wet_Boots

(Apr 27th 2014, 9:26am)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)