You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by RonBLaGrone (Jun 4th 2013, 11:05am)

2 327

by Ronblagrone

(Jun 12th 2013, 10:23pm)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 171

by Wet_Boots

(Jun 9th 2013, 8:14pm)

by ruchuck (May 29th 2013, 8:54am)

7 356

by mrfixit

(Jun 2nd 2013, 12:03am)

by rickthedrummer101 (May 11th 2013, 2:26pm)

1 217

by Wet_Boots

(May 11th 2013, 5:08pm)

by Rmiclette (May 5th 2013, 6:49am)

2 217

by Scott76

(May 5th 2013, 11:41am)

by richard1975 (Apr 28th 2013, 7:12pm)

1 158

by Scott76

(May 2nd 2013, 2:06pm)

by Caltino (Apr 12th 2013, 7:18pm)

12 562

by Wet_Boots

(Apr 27th 2013, 7:42am)

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 220

by mrfixit

(Apr 17th 2013, 5:56pm)

by Kpierce (Apr 12th 2013, 10:36pm)

1 181

by Wet_Boots

(Apr 13th 2013, 10:46am)

by Ianjanson (Apr 10th 2013, 1:37pm)

2 218

by Ianjanson

(Apr 10th 2013, 7:37pm)

Show

Statistics:

428 Threads - 1,620 Posts (average 0.36 Posts per Day)