You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by crashxx (Apr 28th 2012, 12:16pm)

4 918

by crashxx

(May 1st 2012, 9:15am)

by SVKTVKVVK (Mar 22nd 2012, 10:53am)

3 1,889

by mrfixit

(Mar 22nd 2012, 12:43pm)

by raisbarth (Feb 26th 2012, 9:14am)

0 396

No reply

by Shred Happy (Dec 21st 2011, 9:04am)

1 933

by Wet_Boots

(Dec 21st 2011, 12:54pm)

by patk (Sep 18th 2011, 2:17pm)

2 752

by patk

(Sep 18th 2011, 3:41pm)

by Drski (Jul 29th 2011, 11:50am)

5 688

by Drski

(Aug 9th 2011, 11:04am)

by BirdieBob (Aug 4th 2011, 7:01pm)

1 215

by Wet_Boots

(Aug 4th 2011, 9:27pm)

by JohnEmery (Jul 31st 2011, 3:48pm)

1 488

by Wet_Boots

(Jul 31st 2011, 4:16pm)

by Mac54321 (Jul 13th 2011, 10:03am)

1 802

by Wet_Boots

(Jul 13th 2011, 11:30am)

by pillboy (Jun 8th 2011, 6:40pm)

11 3,414

by Wet_Boots

(Jun 14th 2011, 2:26pm)

Show

Statistics:

468 Threads - 1,712 Posts (average 0.36 Posts per Day)