You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by richard1975 (Apr 28th 2013, 7:12pm)

1 214

by Scott76

(May 2nd 2013, 2:06pm)

by Binks (Apr 10th 2013, 1:28am)

1 214

by mrfixit

(Apr 10th 2013, 3:02am)

by mharden5 (Jul 11th 2009, 12:45pm)

1 215

by hi.todd

(Jul 11th 2009, 9:27pm)

by AdamT (Jun 7th 2012, 12:00pm)

2 216

by AdamT

(Jun 7th 2012, 9:14pm)

by Katy (Jun 1st 2012, 3:41pm)

2 216

by hi.todd

(Jun 1st 2012, 8:55pm)

by lloydlevy (Nov 28th 2011, 11:14am)

3 216

by Wet_Boots

(Nov 29th 2011, 8:22am)

by George_S (Jun 26th 2009, 7:13pm)

0 216

No reply

by peterheading (Oct 25th 2005, 5:03pm)

2 216

by Wet_Boots

(Oct 27th 2005, 2:43am)

by aziz786 (Aug 9th 2010, 12:02pm)

2 218

by aziz786

(Aug 10th 2010, 12:49pm)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 219

by Wet_Boots

(Jun 9th 2013, 8:14pm)

Show

Statistics:

436 Threads - 1,654 Posts (average 0.36 Posts per Day)