You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Eclectic (May 17th 2010, 2:01pm)

0 354

No reply

by Mindy (Aug 23rd 2011, 12:33pm)

1 358

by Wet_Boots

(Aug 23rd 2011, 2:30pm)

by noquarter (May 24th 2014, 1:22pm)

6 359

by Wet_Boots

(May 26th 2014, 6:22am)

by jcmckinney1 (Oct 6th 2011, 10:38am)

1 361

by Wet_Boots

(Oct 6th 2011, 6:55pm)

by BirdieBob (Aug 4th 2011, 7:01pm)

1 365

by Wet_Boots

(Aug 4th 2011, 9:27pm)

by Tullamoredew1 (Jun 19th 2009, 8:24pm)

1 365

by hi.todd

(Jun 19th 2009, 10:23pm)

by mugentuner (Aug 30th 2004, 12:30pm)

1 366

by mugentuner

(Sep 6th 2004, 8:44am)

by mellow (May 31st 2015, 7:15pm)

4 367

by mrfixit

(Jun 2nd 2015, 4:08pm)

by Evergreen Sprinkler (Aug 4th 2015, 5:43pm)

0 368

No reply

by frankmanic (Aug 5th 2010, 8:44am)

0 370

No reply

Show

Statistics:

517 Threads - 1,975 Posts (average 0.37 Posts per Day)