You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ksrmc (Aug 1st 2012, 3:27pm)

6 469

by Wet_Boots

(Aug 2nd 2012, 9:31am)

by Jrdcpapc (Aug 1st 2007, 6:17am)

1 298

by SprinklerGuy

(Aug 2nd 2007, 12:41am)

by clm716 (Aug 7th 2011, 9:58am)

1 176

by Central Irrigation

(Aug 7th 2011, 10:49am)

by henry2clue (Jun 1st 2010, 7:30pm)

1 1,430

by mrfixit

(Jun 2nd 2010, 2:27am)

by stktrader (May 20th 2012, 5:55pm)

4 325

by Wet_Boots

(May 21st 2012, 7:02am)

by beanpole (Aug 21st 2010, 10:20pm)

5 857

by Wet_Boots

(Aug 24th 2010, 12:57pm)

by AdamT (Jun 7th 2012, 12:00pm)

2 199

by AdamT

(Jun 7th 2012, 9:14pm)

by rbuchas (May 27th 2011, 2:22pm)

8 1,542

by hi.todd

(Jun 3rd 2011, 4:52pm)

by The Professor (May 26th 2005, 9:47pm)

2 233

by Jazzer K

(Sep 2nd 2005, 6:19pm)

by Island Sprinklers (Mar 12th 2013, 10:47am)

1 403

by Wet_Boots

(Mar 12th 2013, 11:42am)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)