You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by svsprinklers (May 19th 2010, 9:29pm)

2 1,279

by PhoenixDen

(Jun 24th 2010, 11:27am)

by trapkoch (Jul 5th 2009, 10:20am)

1 403

by mrfixit

(Jul 5th 2009, 12:46pm)

by tmshead (Oct 1st 2007, 4:35am)

2 491

by Wet_Boots

(Oct 3rd 2007, 6:52am)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 302

by jmduke7

(Aug 16th 2006, 6:36pm)

by paterjb (Jan 5th 2004, 7:46am)

5 494


(Jan 6th 2004, 3:16pm)

by dkraska (Aug 29th 2009, 2:41pm)

4 598

by hi.todd

(Aug 30th 2009, 9:32pm)

by Val (Jun 17th 2011, 10:57pm)

4 422

by Val

(Jun 18th 2011, 7:07pm)

by mharden5 (Jul 11th 2009, 12:45pm)

1 325

by hi.todd

(Jul 11th 2009, 9:27pm)

by Don_Mousseau (May 15th 2010, 8:44am)

1 747

by mrfixit

(May 15th 2010, 1:03pm)

by ksrmc (Aug 1st 2012, 3:27pm)

6 908

by Wet_Boots

(Aug 2nd 2012, 9:31am)



479 Threads - 1,805 Posts (average 0.36 Posts per Day)