You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by wingnut (Jul 9th 2009, 10:29pm)

1 385

by mrfixit

(Jul 10th 2009, 2:31pm)

by veidtmeister (Jul 29th 2011, 2:02pm)

9 755

by Wet_Boots

(Jul 31st 2011, 3:08pm)

by Rmiclette (May 5th 2013, 6:49am)

2 514

by Scott76

(May 5th 2013, 11:41am)

by kazemi (Sep 5th 2005, 11:57am)

3 523

by Wet_Boots

(Sep 5th 2005, 2:14pm)

by lkc91311 (Jun 26th 2011, 11:25pm)

0 365

No reply

by bombertennis (Jul 9th 2005, 3:20pm)

1 454

by Wet_Boots

(Jul 9th 2005, 3:57pm)

by rickbrum (Apr 18th 2016, 9:13am)

1 43

by Wet_Boots

(Apr 18th 2016, 7:11pm)

by planersedge (Jun 20th 2012, 2:32pm)

3 479

by planersedge

(Jun 25th 2012, 7:27am)

by Katy (Jun 1st 2012, 3:41pm)

2 394

by hi.todd

(Jun 1st 2012, 8:55pm)

by shrpshtr (Apr 26th 2011, 12:32am)

0 523

No reply

Show

Statistics:

497 Threads - 1,879 Posts (average 0.36 Posts per Day)