You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Jimy (Aug 30th 2011, 11:45am)

4 528

by chrisrlewis78

(Sep 4th 2011, 2:52pm)

by John199 (Aug 14th 2011, 3:57pm)

4 667

by hi.todd

(Aug 15th 2011, 7:29pm)

by irar (Jul 11th 2011, 5:27pm)

4 372

by AutomaticSprinklers

(Jul 20th 2011, 8:49pm)

by Val (Jun 17th 2011, 10:57pm)

4 243

by Val

(Jun 18th 2011, 7:07pm)

by rspfau (Jun 9th 2011, 6:12pm)

4 536

by Mitchgo

(Jun 9th 2011, 10:08pm)

by 13dwf (Sep 7th 2010, 1:03pm)

4 433

by Wet_Boots

(Sep 9th 2010, 8:50pm)

by dkraska (Aug 29th 2009, 2:41pm)

4 407

by hi.todd

(Aug 30th 2009, 9:32pm)

by Roger Stover (Jun 16th 2009, 11:09am)

4 135

by hi.todd

(Jun 19th 2009, 10:27pm)

by xfevv (Oct 16th 2007, 4:52am)

4 619

by Cricketkiller

(Jun 7th 2008, 3:53pm)

by perplexed (Sep 8th 2007, 3:35am)

4 503

by perplexed

(Sep 9th 2007, 5:20am)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)