You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by bluetractormanc (Aug 9th 2011, 10:59pm)

1 479

by Wet_Boots

(Aug 10th 2011, 7:51am)

by clm716 (Aug 7th 2011, 9:58am)

1 141

by Central Irrigation

(Aug 7th 2011, 10:49am)

by BirdieBob (Aug 4th 2011, 7:01pm)

1 118

by Wet_Boots

(Aug 4th 2011, 9:27pm)

by JohnEmery (Jul 31st 2011, 3:48pm)

1 328

by Wet_Boots

(Jul 31st 2011, 4:16pm)

by JimB (Jul 30th 2011, 3:59pm)

1 109

by Wet_Boots

(Jul 30th 2011, 4:53pm)

by HHicks (Jul 22nd 2011, 4:57pm)

1 539

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 311

by Mitchgo

(Jul 19th 2011, 12:34am)

by veidtmeister (Jul 15th 2011, 9:03pm)

1 191

by Wet_Boots

(Jul 15th 2011, 11:06pm)

by Mac54321 (Jul 13th 2011, 10:03am)

1 590

by Wet_Boots

(Jul 13th 2011, 11:30am)

by ncampbel (Jul 1st 2011, 2:15pm)

1 509

by Mitchgo

(Jul 1st 2011, 9:20pm)

Show

Statistics:

419 Threads - 1,565 Posts (average 0.35 Posts per Day)