You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by John199 (Aug 14th 2011, 3:57pm)

4 645

by hi.todd

(Aug 15th 2011, 7:29pm)

by irar (Jul 11th 2011, 5:27pm)

4 356

by AutomaticSprinklers

(Jul 20th 2011, 8:49pm)

by Val (Jun 17th 2011, 10:57pm)

4 231

by Val

(Jun 18th 2011, 7:07pm)

by rspfau (Jun 9th 2011, 6:12pm)

4 520

by Mitchgo

(Jun 9th 2011, 10:08pm)

by 13dwf (Sep 7th 2010, 1:03pm)

4 422

by Wet_Boots

(Sep 9th 2010, 8:50pm)

by dkraska (Aug 29th 2009, 2:41pm)

4 389

by hi.todd

(Aug 30th 2009, 9:32pm)

by Roger Stover (Jun 16th 2009, 11:09am)

4 125

by hi.todd

(Jun 19th 2009, 10:27pm)

by xfevv (Oct 16th 2007, 4:52am)

4 605

by Cricketkiller

(Jun 7th 2008, 3:53pm)

by perplexed (Sep 8th 2007, 3:35am)

4 490

by perplexed

(Sep 9th 2007, 5:20am)

by Marlene (Aug 23rd 2007, 3:11am)

4 386

by Marlene

(Aug 25th 2007, 5:42am)

Show

Statistics:

435 Threads - 1,641 Posts (average 0.36 Posts per Day)