You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ASV (May 11th 2015, 6:30am)

1 95

by Wet_Boots

(May 11th 2015, 8:09am)

by PabloCruise (May 3rd 2015, 4:28pm)

3 59

by Wet_Boots

(May 4th 2015, 11:53am)

by DJM8507 (Apr 28th 2015, 12:21pm)

0 90

No reply

by 95mmrenegade (Jul 20th 2014, 10:30am)

4 154

by Central Irrigation

(Jul 20th 2014, 2:43pm)

by LT87 (May 21st 2014, 11:33am)

3 196

by hi.todd

(May 27th 2014, 1:03pm)

by andyl (Apr 21st 2014, 8:32pm)

3 272

by Wet_Boots

(Apr 27th 2014, 9:26am)

by Gansmanms (Nov 7th 2012, 9:10pm)

7 1,833

by marian

(Sep 2nd 2013, 5:37pm)

by edwildesr (Oct 7th 2007, 7:02pm)

2 1,741

by mrfixit

(Aug 26th 2013, 8:00pm)

by sdguy (Mar 10th 2013, 3:15pm)

3 597

by Wet_Boots

(Jul 31st 2013, 10:41am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 821

by 4U2NVME

(Jul 17th 2013, 12:01pm)

Show

Statistics:

458 Threads - 1,728 Posts (average 0.36 Posts per Day)