You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Montgomeryc (Jun 13th 2012, 2:46pm)

1 453

by Wet_Boots

(Jun 13th 2012, 4:03pm)

by 0303maz (Jun 12th 2012, 9:20am)

1 218

by mrfixit

(Jun 12th 2012, 9:45am)

by harrisst14 (Jun 10th 2012, 6:29pm)

1 738

by mrfixit

(Jun 10th 2012, 8:13pm)

by AdamT (Jun 7th 2012, 12:00pm)

2 247

by AdamT

(Jun 7th 2012, 9:14pm)

by Katy (Jun 1st 2012, 3:41pm)

2 241

by hi.todd

(Jun 1st 2012, 8:55pm)

by tbone136 (May 24th 2012, 9:46am)

0 150

No reply

by kenttab (May 21st 2012, 5:51pm)

1 786

by mrfixit

(May 21st 2012, 8:58pm)

by Cherrybark (May 20th 2012, 6:22pm)

2 359

by GatorGuy

(May 21st 2012, 9:04am)

by stktrader (May 20th 2012, 5:55pm)

4 379

by Wet_Boots

(May 21st 2012, 7:02am)

by odiaz1 (May 10th 2012, 10:18am)

1 402

by Wet_Boots

(May 10th 2012, 10:26am)

Show

Statistics:

463 Threads - 1,708 Posts (average 0.37 Posts per Day)