You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by mack (Apr 18th 2012, 8:30pm)

2 358

by mack

(Apr 19th 2012, 12:54pm)

by jack z (Apr 8th 2012, 10:35am)

1 352

by mrfixit

(Apr 8th 2012, 2:37pm)

by opsec (Apr 1st 2012, 7:44pm)

2 346

by Wet_Boots

(Apr 2nd 2012, 9:08am)

by SVKTVKVVK (Mar 22nd 2012, 10:53am)

3 1,202

by mrfixit

(Mar 22nd 2012, 12:43pm)

by ros (Mar 15th 2012, 7:40pm)

1 344

by hi.todd

(Mar 20th 2012, 9:07pm)

by aa1872 (Mar 17th 2012, 8:22am)

3 170

by GatorGuy

(Mar 19th 2012, 8:41am)

by Jonas_ (Mar 13th 2012, 9:40am)

10 1,367

by Wet_Boots

(Mar 16th 2012, 8:14am)

by Jonas_ (Mar 14th 2012, 6:16am)

1 285

by GatorGuy

(Mar 14th 2012, 7:35am)

by Brassguy (Feb 26th 2012, 4:36pm)

5 318

by Brassguy

(Mar 8th 2012, 10:09pm)

by raisbarth (Feb 26th 2012, 9:14am)

0 242

No reply

Show

Statistics:

419 Threads - 1,565 Posts (average 0.35 Posts per Day)