You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by wkneis@optonline.net (Apr 9th 2006, 5:52pm)

3 250

by xpedient

(Jul 2nd 2006, 3:34pm)

by gregson (Jul 22nd 2006, 10:14am)

2 128

by nestors

(Aug 2nd 2006, 6:26pm)

by fatelvis00 (Aug 4th 2006, 2:58pm)

1 478

by mrfixit

(Aug 7th 2006, 1:26am)

by bobottolini (Jul 10th 2006, 12:27pm)

3 261

by jmduke7

(Aug 16th 2006, 6:30pm)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 173

by jmduke7

(Aug 16th 2006, 6:36pm)

by korangu2004 (Aug 16th 2006, 5:56pm)

3 1,007

by jmduke7

(Aug 17th 2006, 3:00pm)

by gerald (May 31st 2006, 5:44am)

2 136

by jmduke7

(Aug 17th 2006, 3:03pm)

by pohall@kivexmail.com (May 13th 2006, 9:21am)

1 694

by jmduke7

(Aug 17th 2006, 3:13pm)

by jackevln (Aug 20th 2006, 6:33am)

4 271

by mrfixit

(Aug 21st 2006, 5:12pm)

by fireman (Sep 15th 2006, 3:14pm)

8 457

by mrfixit

(Sep 19th 2006, 9:59am)

Show

Statistics:

429 Threads - 1,622 Posts (average 0.36 Posts per Day)