You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by tommysaxboy (May 22nd 2016, 3:13pm)

1 34

by Wet_Boots

(May 22nd 2016, 6:10pm)

by Heymikie (Jun 6th 2016, 3:05pm)

1 63

by hi.todd

(Jun 6th 2016, 7:43pm)

by ChucksLandscaping (Apr 20th 2016, 11:19am)

0 63

No reply

by DKW (Jun 3rd 2016, 10:11am)

3 67

by mrfixit

(Jun 6th 2016, 2:22pm)

by Rey@@%% (Mar 26th 2016, 12:04pm)

0 77

No reply

by kp007 (Mar 22nd 2016, 10:42am)

3 85

by Wet_Boots

(Mar 22nd 2016, 12:35pm)

by Chrism (Jun 25th 2016, 3:20pm)

5 94

by Wet_Boots

(Jun 26th 2016, 8:01am)

by bjlarson (Jul 28th 2015, 9:20am)

1 100

by Wet_Boots

(Jul 28th 2015, 10:04am)

by pkilbride (May 3rd 2015, 8:44pm)

0 103

No reply

by Grady (Apr 30th 2016, 9:52pm)

2 112

by Wet_Boots

(May 1st 2016, 10:54am)

Show

Statistics:

508 Threads - 1,950 Posts (average 0.37 Posts per Day)