You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Terri (Jan 9th 2013, 6:46am)

1 258

by Wet_Boots

(Jan 9th 2013, 11:08am)

by blh (Jun 4th 2011, 12:55pm)

1 289

by Mitchgo

(Jun 4th 2011, 3:32pm)

by grph (Aug 31st 2005, 3:56am)

1 178

by Jazzer K

(Sep 2nd 2005, 6:25pm)

by JohnEmery (Jul 31st 2011, 3:48pm)

1 338

by Wet_Boots

(Jul 31st 2011, 4:16pm)

by 7907 (May 3rd 2013, 12:55am)

2 179

by PennyInHeels

(Jun 25th 2013, 9:49am)

by wetyet (Apr 6th 2006, 4:16pm)

2 93

by wetyet

(Apr 7th 2006, 4:01pm)

by jjgoss (Feb 6th 2006, 8:35am)

5 193

by lush96

(Mar 19th 2006, 7:32pm)

by tbone136 (May 24th 2012, 9:46am)

0 104

No reply

by joe decoste (Mar 19th 2011, 11:56am)

1 148

by Wet_Boots

(Mar 20th 2011, 7:29am)

by spensito (Feb 16th 2006, 6:52am)

7 234

by lush96

(Mar 19th 2006, 7:16pm)

Show

Statistics:

421 Threads - 1,569 Posts (average 0.35 Posts per Day)