You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by WS-1 (May 9th 2010, 4:29pm)

28 8,143

by Romeo

(Jun 10th 2014, 3:57am)

by GregM (Mar 17th 2011, 9:20am)

23 3,086

by mrfixit

(Nov 1st 2012, 9:39pm)

by korangu2004 (Aug 8th 2006, 7:54am)

22 28,993

by kjaaka

(Jul 18th 2013, 7:19pm)

by chrisrlewis78 (Aug 4th 2011, 6:51pm)

18 1,896

by chrisrlewis78

(Aug 31st 2011, 4:50pm)

by Bob H (May 13th 2003, 12:54am)

17 643

by Bob H

(Jun 3rd 2003, 9:20am)

by Caltino (Apr 12th 2013, 7:18pm)

12 685

by Wet_Boots

(Apr 27th 2013, 7:42am)

by badsprinklers (Oct 10th 2007, 4:55pm)

12 2,175

by Wet_Boots

(Apr 27th 2008, 11:09am)

by pillboy (Jun 8th 2011, 6:40pm)

11 2,897

by Wet_Boots

(Jun 14th 2011, 2:26pm)

by jwdawgs (Feb 26th 2007, 4:10pm)

11 422

by Tom

(Feb 28th 2007, 12:48pm)

by WHomeowner (Jul 24th 2011, 2:16pm)

10 1,293

by PennyInHeels

(Jun 25th 2013, 3:52pm)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)