You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by dsmayse (Oct 24th 2015, 10:43am)

3 382

by Wet_Boots

(Oct 25th 2015, 5:55pm)

by Lonesomedave (Oct 16th 2015, 7:38am)

1 213

by Wet_Boots

(Oct 16th 2015, 10:46am)

by 09KR0058 (Oct 13th 2015, 6:11pm)

1 76

by 09KR0058

(Oct 13th 2015, 6:42pm)

by korangu2004 (Aug 8th 2006, 7:54am)

28 40,991

by Mark the Rainbird User

(Sep 20th 2015, 8:56am)

by MichaelABQ (Sep 15th 2015, 1:11am)

1 63

by mrfixit

(Sep 15th 2015, 4:19am)

by Dagobah (Sep 3rd 2015, 3:46pm)

3 459

by Evergreen Sprinkler

(Sep 11th 2015, 9:41am)

by 88goldwing (Sep 1st 2015, 2:28pm)

12 425

by 88goldwing

(Sep 8th 2015, 5:36pm)

by JimsLawn (Sep 8th 2015, 2:33pm)

0 96

No reply

by PAP (Aug 19th 2015, 10:04am)

2 373

by PAP

(Sep 8th 2015, 9:57am)

by Artie (Sep 2nd 2015, 7:27am)

1 216

by Wet_Boots

(Sep 2nd 2015, 8:10am)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)