You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by mtmtntop (May 8th 2016, 4:22pm)

7 122

by Wet_Boots

(Yesterday, 7:09pm)

by DeadImperial (May 22nd 2016, 8:17pm)

20 149

by Wet_Boots

(Yesterday, 3:15am)

by tommysaxboy (May 22nd 2016, 3:13pm)

1 13

by Wet_Boots

(May 22nd 2016, 6:10pm)

by rickbrum (Apr 18th 2016, 9:13am)

4 143

by hoosudaddy

(May 13th 2016, 3:13pm)

by Greenweenie (Jun 21st 2010, 9:15am)

3 4,285

by Call-me-goose

(May 12th 2016, 7:17am)

by JT (Mar 9th 2014, 8:08pm)

2 514

by scbsprinkler

(May 6th 2016, 8:32pm)

by Grady (Apr 30th 2016, 9:52pm)

2 97

by Wet_Boots

(May 1st 2016, 10:54am)

by BostonStrong (Apr 26th 2016, 5:45pm)

3 97

by BostonStrong

(Apr 27th 2016, 8:33pm)

by jhkatytx (Apr 14th 2016, 5:36pm)

8 195

by jhkatytx

(Apr 23rd 2016, 3:47pm)

by ChucksLandscaping (Apr 20th 2016, 11:19am)

0 41

No reply

Show

Statistics:

500 Threads - 1,915 Posts (average 0.37 Posts per Day)