You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Dagobah (Yesterday, 3:46pm)

0 8

No reply

by 88goldwing (Sep 1st 2015, 2:28pm)

10 112

by 88goldwing

(Yesterday, 10:19am)

by Artie (Sep 2nd 2015, 7:27am)

1 16

by Wet_Boots

(Sep 2nd 2015, 8:10am)

by GT6812 (Aug 28th 2015, 8:40am)

2 63

by GT6812

(Aug 31st 2015, 11:15am)

by PAP (Aug 19th 2015, 10:04am)

1 147

by Wet_Boots

(Aug 19th 2015, 12:15pm)

by mjtalmadge (Sep 11th 2011, 2:30pm)

11 4,868

by wgn1213

(Aug 18th 2015, 1:23pm)

by fbg (Aug 13th 2015, 4:40pm)

1 129

by Central Irrigation

(Aug 13th 2015, 6:38pm)

by denver9 (Aug 10th 2015, 10:47pm)

3 100

by Wet_Boots

(Aug 12th 2015, 3:44am)

by sijaz (Aug 11th 2015, 12:25am)

3 75

by mrfixit

(Aug 11th 2015, 2:35pm)

by ScorpioTravis (Aug 10th 2015, 1:06pm)

0 63

No reply

Show

Statistics:

477 Threads - 1,795 Posts (average 0.36 Posts per Day)