You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 998 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 2 posts

Sunday, July 31st 2011, 4:16pm

by Wet_Boots

Nelson sold its sprinkler division to Signature, so you want to get their tech support.

Sunday, July 31st 2011, 3:48pm

by JohnEmery

8616 NELSON EZ PRO controller problems

I am new at sprinkler systems... This system is about 9 years old... Starting to have problems... This is a 16 zone controller... zone 2 lead stopped opening the solenoid... I moved lead wire to zone 3 lead and it opens both... Is that OK?
Also zone 10 stopped opening about the same time... I think the solenoid must be bad on that one... Also the controller is equipped with a remote control module that we are not using however it is very very hot to the touch and I can't figure out why... I am not sure if it is OK to disconnect it or not and how...