You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 895 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 4 posts

Saturday, April 7th 2012, 7:11am

by jer (Guest)

Dig it up and see what the problem is.

Tuesday, April 24th 2007, 11:08am

by moscafj

Suggestions for proceeding with a repair?

Tuesday, April 24th 2007, 4:44am

by Tom

Its screwed into a fitting, but the pipe and/or head fitting is probably busted.

Monday, April 23rd 2007, 7:40am

by moscafj

Weathermatic problem

I inherited a sprinkler system when I purchased my home about a year ago. I really don't know anything more than how to control the system.

Problem: Weathermatic T3...When I activate the system, one sprinkler rises up from the ground and falls over as water bubbles up from the system. I can figure out how to re-attach the sprinkler. I can put it back in the hole, but clearly it must attach to someting.

Any suggestions?

Thanks