You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 3384 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 5 posts

Sunday, June 12th 2005, 6:45pm

by RidgeRun05

Amen

Saturday, June 11th 2005, 6:57pm

by Wet_Boots

That's why they invented beer.

Saturday, June 11th 2005, 5:58pm

by ppotter

Tony,

Thanks for the help. I guessed that new spray heads was probably the way to go, but just don't fancy digging holes in the Memphis heat!

Thanks,

Phil

Saturday, June 11th 2005, 5:04pm

by RidgeRun05

Assuming you are truly talking about the spray heads, and not the rotor type heads, I would suggest replacing them. You can replace them with a different model, or even a different brand if you'd like. I suggest the Hunter Pro Series spray or the RainBird 1800 series. For as cheap as these heads are, it is often more efficient to just replace the entire assembly. The leak around your seal on the head is most likely either a cracked body or a broken wiper seal. My advice, Replace them both.

Friday, June 10th 2005, 7:53am

by ppotter

Problem sprinkler head

Hi,

I have one sprinkler head in a zone that does not pop up. It will raise about 1 inch and then flood the area with water. I have cleaned the filter (its a Rainbird model, but not sure of the model number) with no success. Is the only alternative to replace the head?

Also I have another head in a different zone that leaks from the point where the pop up tube arises from the body of the head. This only happens when the system is running but is creates a large stream of water on my pathway. The head sprays water OK. It looks as though it is leaking from a white collar/gasket around the pop up. Again this is a Rainbird model. Is this fixable or do I need a new head.

Finally if I have to replace either of these heads, will it be a problem replacing them with different Rainbird models. My system is about 10 years olfd and I am not sure I will be able to find identical heads. I still want spray heads, but not sure if I can mix different model numbers OK.

Thanks