You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 2606 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 6 posts

Tuesday, June 12th 2007, 8:31pm

by lush96

i-20's are not that good a head. the 5 year warranty is the only good point. stick with the pgp's. much much more reliable head.

Wednesday, June 21st 2006, 2:35pm

by Tom



hunter lists the recommended operating for the pgp and I-20 at 40 psi. they also list the miniumum operating pressure as 20 psi for both heads.

you must have done something wrong and/or you have a leak on these zones resulting in very low pressure to the head.

Tuesday, June 20th 2006, 3:09pm

by Wet_Boots

You could try swapping springs with the old heads, but basically, you stick with the PGPs

Tuesday, June 20th 2006, 1:06pm

by Hansston

So, my choices are to put a booster pump on my system to increase the pressure or go back to the PGP's?

Tuesday, June 20th 2006, 12:26pm

by Wet_Boots

Your new sprinklers have stronger springs than the old ones. You see the result.

Tuesday, June 20th 2006, 8:01am

by Hansston

Hunter I20 SS Won't Pop Up

I have an acre of lawn and have a ton of sprinklers, all PGP. When the PGP's need to be replaced, I decided to upgrade to I20 stainless steel sprinklers. I ordered 10 to test them out and when installed, they won't pop up. When I manually pull up the sprinkler with the adjustment tool, the sprinkler works fine, but I can't get the sprinkler to pop up on it's own. I tried 3 zones to no avail.

Is there an easy solution to this problem? Do the SS models need lubrication?