You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 3071 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 3 posts

Saturday, May 27th 2006, 4:36pm

by GregLamb

Thx Tony--I subsequently replaced the whole injector unit. Seems to be working fine this season although its hard to get primed the first time...

/GREG

Tuesday, June 14th 2005, 7:51pm

by RidgeRun05

Most likely either your pressure is too high, or your injection system is shot. Which Fertigator device do you have, and what is your supply line pressure. If your supply line pressure hasn't changed recently, you can pretty much rule that out. Check all of your wiring, maybe the Fertigator unit is not functioning at all. If you know the wiring is OK, and the system is fertilizing properly, I would double check the unit it self. Make sure there is no clog within the supply line or the mainline pipe itself. Let me know what you find.

Monday, June 13th 2005, 7:58pm

by GregLamb

Fertigator supply line question

My fertigator has been installed for two years and has worked perfectly. However, last year the suction line drew from the supply container until it was empty. Once this was completed, it would refill the container with water.
This year it seems to mix the water with the liquid fertilizer so I never know when its really empty. its always full. What's wrong... ?