You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 2907 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 6 posts

Tuesday, May 9th 2006, 5:04pm

by RidgeRun05

Yes, place the arc disk in, then screw on the appropriate radius cap. The body pops up just like any other rotor type head.

Friday, May 5th 2006, 3:17am

by jellman

So when you put in one of the muli-disk did you then screw it down and then put the radius cap on. What exactly pops up, the housing that disk sits in?

Thursday, May 4th 2006, 4:46pm

by RidgeRun05

Installed them yesterday. The head pops up like any other rotor. It may be defective. I would first flush out your lines to make sure there is nothing in the pipe, then I would take it back if it still doesn't work. Sounds like everything else you did installing it was right.

Wednesday, May 3rd 2006, 2:43am

by jellman

Yes all the other heads on the zone came up and I do get water to bubble out of the head. Even if you look at the 340 it doesn't look right, I can't see how the shaft part can even pop up. I'm trying to avoid digging and taking apart, but that looks like maybe the next step, unless someone has used these heads of recent.

Tuesday, May 2nd 2006, 2:10pm

by RidgeRun05

Did the existing sprinkler head pop up without trouble? Did you flush the lines out before installing the new head? It could be something got into the pipe. If none of the heads are popping up, it could be a pressure issue or a possible leak.

Tuesday, May 2nd 2006, 9:23am

by jellman

Toro 340 Stream Will Not Pop Up

Just purchased Toro 340 Stream Lawn Pop up. They come with the multidisk that you put in to get the desired angle to water. And then you screw on the radius cap. But for some reason, I have to be missing something, they will not pop up, water just gushes out just below the radius cap. But I can't seem to see how these pop up. They both do this.
Any thoughts [?]