You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 3415 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 3 posts

Friday, July 22nd 2005, 12:44pm

by HooKooDooKu

The first though that came to my mind was "dirty" equipment. Have you tried openning one of the spray heads and checking the filter screens behind them? If the system doesn't have a common filter, I could see where 6 years of use (even on city water)

What about pieces of grass, grit, dirt, that might have gotten inside the popups over the years.

The only other thing that comes to mind is some sort of major blockage in the main line and/or Bcak Flow Preventer or a major leak somewhere.


Friday, July 22nd 2005, 6:43am

by pmahan


What did you discover your problem was? I have same problem I believe... and if it was your backflow problem, where is it located, and how changed?

Thursday, June 30th 2005, 4:10am

by rsuber

Low pressure all zones?

I have a six zone system on city water. I measure approx 85 psi from the ourdoor faucet. All zones seem to have low pressure, heads not popping op completely, poor water spray, etc. Should I look at the main anti-backflow valve since this is the common device? Is so, what do I need to look for? This system has been installed for 6 years.

Thanks
Rick