You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 3718 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 2 posts

Friday, August 20th 2004, 10:26am

by billingsleyj

Look at cleaning out your nozzels and filters on the Nelsons. Dental floss works well on the nozzles while the system is running. Wear your swimsuit!

Thursday, August 19th 2004, 6:42am

by jibs

anemic pop up sprayers

Last year I had a system put in. My pop up sprayers all seem to not be putting out like they should. The heads are Nelson (12' nozzles). This weekend I went to Home Depot and bought 3 generic pop up sprayers (12' nozzles) and put them in place of 3 of the Nelsons. The generic ones work awesome, the Nelsons just suck. I thought maybe my pressure was low, because the Nelson heads barely pop up and cover only about half of the area they should. Since the generic one's work so well I think it is the heads. What could be going on? Should I just junk all the Nelson heads and forget that I may have a problem? I have flushed the system. I haven't found any leaks.