You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 897 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 4 posts

Monday, May 30th 2016, 11:40am

by Wet_Boots

The existing valve body might need a cleaning before you seat the adapter. In any event, teflon tape won't gum up the works, so apply what you need. Since the original Champion valve bodies used a gasket for a seal, the O-ring is a bit of a surprise.

Monday, May 30th 2016, 11:22am

by ears54 (Guest)

orbit converter valve leak

Mrfixit, thanks for the reply.

I don’t have a pic of the installation but I’ve attached one of the valve itself. The leak is definitely
from where the adapter seats and these valves use o-rings. I will try the grease and possibly the Teflon tape. I had not thought of the fiber washers.


Sunday, May 29th 2016, 11:33pm

by mrfixit

I never install the adapter in question but I do install the Irritrol 300 which usues an O-ring instead of a fiber washer. I've uninstalled a pile of them though.
If you over tighten it the O-ring might leak.
You could try using a 1" fiber washer instead of the O-ring.
Some people put teflon tape on the threads. I don't recommend that but it would probably work.
Are you sure the water's coming from where the adapter seats and not from the cap side of the valve? Did you check the washer on the float and the washer under the cap? I'm just assuming you have ASV's. Maybe you have angle valves.
Can you post a pic of the valve? Go to www.tinypic.com and cut n past the forum code here after you've uploaded your photo.
To answer your question about grease, It might help. One way to find out.

Sunday, May 29th 2016, 9:22pm

by ears54 (Guest)

orbit converter valve leak

replacing old valves with new. Orbit model 57030 1" brass. After installing the new valve into the brass valve body, I have a couple of valves leaking where the two brass parts meet. I have cleaned and leveled the face of the valve body and I do see any issue in the o-ring seat. The instructions do not mention using any grease or sealant for this connection, but I wonder if a bit of valve grease or silicon grease might help.

Thanks