You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 4067 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 2 posts

Wednesday, August 13th 2003, 8:13am

by Rays Sprinklers

Where exactly is it leaking, at the threads, or at the bell housing...if it is at the threads then it needs to be removed (make sure you applied significant teflon tape) and re-attach.....if it is at the bell housing then there must be something inside making it not able to seal. or it is a bad backflow. Let us know what you find!

Thanks
Ray
Rays Above and Beyond Automatic Lawn Sprinklers

Monday, August 11th 2003, 11:21am

by MMERSCH

FEBCO pvb leaks under pressure

I could use some help. Hooked up FEBCO pvb yesterday and turned
system on and it is not give a tight seal under pressure. Took bell
housing top off and there does not appear to be anything in there, in
fact if I pull up on the spring it will seal. Also if I close the
ball cock so the water pressure is in the pvb it seals and does
not leak also. Any ideas why it would leak?

Mark

Mark