You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 542 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 2 posts

Sunday, April 28th 2013, 6:17pm

by Wet_Boots

Replace the diaphragm assembly with an Irritrol part.

Sunday, April 28th 2013, 3:58pm

by joeaf

Richdel 216 not working

I have a valve that is over 35 years old and was working a few moths ago. It is a Richdel 216 and you can hear the water flowing when the station is turned on but there is not enough pressure to pop up the sprinkler heads although you can see some water coming out. I replaced the solenoid and still the same thing. Any ideas and where to get the parts?