You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 701 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 2 posts

Saturday, August 25th 2012, 2:19pm

by grey

Done! Replaced under warranty, no questions asked. Took it off, brought it to the store, put on the new one. Now I am back and running. Thumbs up for Hunter!

Friday, August 24th 2012, 6:29pm

by grey

Hunter Pro-C: blank display

I just found out that my Hunter Pro--C seems to be rather dead than alive. I had it off for a couple of days. I tested power outlet, transformer output and the voltage is fine there. I cycled power as per Hunter's article Hunter Still nothing, so I guess it's dead? It is installed indoors and there is rain sensor. There was really bad thunderstorm the other day. I tried calling Hunter support but it's already weekend overthere. I wonder if they replace it under warranty. ?(