You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 778 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 5 posts

Monday, August 6th 2012, 10:11am

by tilleyii (Guest)

Richdel R 205 will not shut off

That is what I was considering. Assume the body is identical and just the guts are different?

Monday, August 6th 2012, 9:56am

by mrfixit

Buy a new valve with flow control. Swap out the parts.
205

Monday, August 6th 2012, 7:16am

by tilleyii (Guest)

Richdel R 205 will not shut off

The replacement R205 was for a 204. The 204 would turn on and then not turn off. This is a non-flow valve as best I can tell and dies not have a flow adjuster.

Sunday, August 5th 2012, 9:23pm

by mrfixit

Are you saying the guy replaced your valve with a Richdel 205?
Try turning the flow control down until it restricts the flow of water then back it off some... If that flow control's open all the way the valve might stick on....
It's not a cracked valve body and if someone told you that they're clueless...

Sunday, August 5th 2012, 8:05pm

by tilleyii (Guest)

Richdel R 205 will not shut off.

Richdel R 205 will not shut off. Valve was replaced with same problem. Sometimes it works, sometimes not. Replaced diaphragm and solenoid with no change. Technician I had working on it said it might be a crack in the valve body. Suggestions? Voltages to the solenoid are good.